BSC experiencing slowdown
Resolved·Degraded performance

BSC is fully caught up.

Tue, Oct 7, 2025, 06:22 PM
(2 months ago)
·
Affected components
Updates

Resolved

BSC is fully caught up.

Tue, Oct 7, 2025, 06:22 PM

Monitoring

A fix has been implemented to deal with unprecedented volumes on BSC and we are in the process of catching up in all of our systems.

Tue, Oct 7, 2025, 06:04 PM(17 minutes earlier)

Identified

BSC is experencing a slowdown. Our team is investigating.

Tue, Oct 7, 2025, 12:05 PM(5 hours earlier)