CloudFlare Disruptions Impacting RPC Providers
Resolved·Degraded performance

Everything working as normal

Tue, Nov 18, 2025, 04:56 PM
(3 weeks ago)
·
Affected components
Updates

Resolved

Everything working as normal

Tue, Nov 18, 2025, 04:56 PM

Investigating

The remaining services are now operational.

Tue, Nov 18, 2025, 04:55 PM

Investigating

Additional RPC providers have been introduced to our pipeline to help mitigate the CloudFlare issues impacting some of our providers. A small handful of Layer 3 networks are still experiencing ongoing impacts.

Tue, Nov 18, 2025, 03:01 PM(1 hour earlier)

Investigating

We are currently experiencing disruptions affecting a small group of networks, due to RPC provider degradations related to the ongoing CloudFlare outage. We are rotating RPC providers on the affected networks, and mitigating wherever possible.

Tue, Nov 18, 2025, 11:37 AM(3 hours earlier)