Resolved
Everything is back to normal. We identified an inefficient path in a field resolver that when used at high scale could degrade the request timing to the point of timing out the origin.
Identified
Some queries containing balances have higher latency than normal latency. We have identified the issue and are working on a solution