Resolved
Codex API services are fully operational. We are working with Amazon Web Services to determine causes and future mitigations of their degraded services we experienced.
Monitoring
We have implemented a workaround, while we continue to monitor the Amazon Web Services degradation. Codex API services are returning to full operation.
Identified
We have identified the source of the degradation to be Amazon Web Service's (AWS) internal networking timeouts. We have escalated support with AWS to work out a resolution as quickly as possible.
Investigating
We are currently investigating degraded performance within the FilterTokens API endpoint. Consumers may experience degraded pair aggregate data while the team is working on a resolution.