·
System has recovered. BNB wallet balance data is up-to-date.
Resolved
Monitoring
We've identified the issue and put a fix in place. We will monitor recovery.
Investigating
Wallet balance calculations are delayed for BNB